Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 25, 2024 - 07:00 UTC
Scheduled
We will update the internal reporting functionality and therefore have a maintenance planned. During the maintenance the internal reporting functionality will not be available.
Posted May 24, 2024 - 20:41 UTC
This scheduled maintenance affected: Meisterplan Application (US Region) (Web Application) and Meisterplan Application (EU Region) (Web Application).