Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 01, 2025 - 20:00 UTC
Scheduled
We will perform scheduled maintenance during this time. As we are upgrading our messaging infrastructure Meisterplan will not be available during the maintenance period.
Posted Jan 22, 2025 - 15:59 UTC
This scheduled maintenance affected: Meisterplan Application (EU Region) (Authentication/SAML, API/Mobile App/Integrations, Subscription Management, Web Application) and Meisterplan Application (US Region) (Authentication/SAML, Web Application, API/Mobile App/Integrations, Subscription Management).