Meisterplan Homepage Down

Incident Report for Meisterplan

Resolved

The problem was resolved and the website is available again.
Posted Aug 25, 2025 - 09:45 UTC

Investigating

We are investigating an outage of the Meisterplan Website. The application at https://eu.meisterplan.com and https://us.meisterplan.com are not affected by this issue.
Posted Aug 25, 2025 - 09:28 UTC
This incident affected: Website.