Meisterplan Support Portal unavailable

Incident Report for Meisterplan

Resolved

This incident has been resolved.
Posted Aug 31, 2026 - 13:02 UTC

Investigating

We are currently investigating reports of customers that raising a support ticket is not possible.
In the meantime please contact our support via support@meisterplan.com.
Posted Aug 31, 2026 - 12:03 UTC